Welcome to ClaroIdeas

ClaroIdeas is an easy-to-use tool to support the creation and editing of concept or idea
maps using visual and audio components. It has been specifically developed to support
people with wide age and ability ranges. We have tried to keep the complexity of the
program down whilst still retaining the functionality of an idea map.

ClaroIdeas Overview
An idea map is a diagram used to represent ideas or concepts linked to a central key
idea or concept. Idea maps are used to visualise, structure and classify ideas, and as an
aid in organisation, problem solving, decision making, writing and study.

With ClaroIdeas you can quickly and easily create idea maps using a combination of
words, symbols and pictures.
You can record your thoughts and ideas as audio files, as well as text and have them
displayed in colourful, meaningful idea maps.

ClaroIdeas integrates fully with ClaroRead, allowing all text ideas to be spoken back in a
human quality voice.
You can enter additional notes for each node or idea, by typing or using Dragon
NaturallySpeaking.
You can export your idea map directly to Microsoft Word and Microsoft PowerPoint, or
have them converted into a PDF document or a picture file.

ClaroIdeas Ribbon
The ClaroIdeas Ribbon Home tab consists of several groups - Autocreate, Clipboard,
Font, Format, Idea, Whole Map, Link and Hyperlinks.

The View tab contains the following groups: Idea Map Views, Show/Hide and Zoom.

Not all of the ribbon groups will be visible all of the time. E.g. When an Idea has been
selected on the idea map the Links group will be hidden; and when a Link has been
selected on the idea map the Idea and Hyperlink groups will be hidden.
Note: For full details of when each group of the ribbon is or isn't displayed, refer to the
relevant section of this help file.
The ClaroIdeas Ribbon can be hidden which allows more space to display your idea map.
To do this, select the menu item Minimise the Ribbon on the Quick Access Toolbar
menu. When the ribbon is hidden you can temporarily show it by clicking on the Home
button. To display the ribbon again permanently, click the Minimise the Ribbon menu
item again.
The Idea group of the ribbon may be labelled as either Default Idea or Current Idea
depending on whether an idea has been selected on the idea map or not. Any ribbon
button which you would like quick access to can be added to the Quick Access Toolbar.
To do this, right click on the desired button in the ribbon and selecting the menu option
Add To Quick Access Toolbar.

Autocreate Group
Use the Autocreate group to quickly add several new ideas to the idea map.

The Autocreate button toggles the Autocreate edit box on and off. To start using the
Autocreate feature click the Autocreate button to show the Autocreate edit box.

You can quickly add new ideas to your idea map by simply typing text into the
Autocreate edit box and either pressing enter, or clicking the button to the right of the
edit box. The new ideas are added to the idea map with a link from the currently
selected idea.
If the "Link idea to parent" box is checked, the new idea will be linked to the currently
selected idea. If it is not checked, the idea will be created next to the currently selected
idea but will not be linked to it.
When you have finished with the Autocreate feature you can click the Autocreate
button again to hide the edit box.
The new ideas created with the Autocreate feature will use the same formatting options
(shape, colour, picture etc.) as the currently selected Idea.

Clipboard Group
From the Clipboard group you can copy, paste, cut and deleted selected shapes, images
or text from your idea map.
Select the shape, image or text by clicking on it, then select which option you would like
to perform on the Clipboard group.
Copy: copy the current selection to the clipboard

Paste: paste the clipboard contents
Cut: remove the current selection and place in the clipboard
Delete: remove the current selection
It is possible to select several items at a time on the idea map. Click the first item you
would like to select, then hold down the Ctrl key while you click on the other items you

would like to select. Alternatively, you can select multiple items by right clicking on the
diagram and dragging your mouse to create a box. All items inside the box when you
release your right mouse button will be selected.
You can use the Undo option (found on the Quick Access Toolbar) to undo any
editing operation.

Font Group
The Font group options let you change the text style, size and colour of text contained
within shapes or in the notes section.

Select the shape containing the text you want to change or select the text in the notes
section.
There are 2 dropdown selections one to change font face and one to change the font
size.
You can also change the font size by using either the Grow font or the Shrink
font buttons.
You can also change the text colour by selecting from the dropdown colour list.
Note: The Underline button is only available for text in an Idea Note. You cannot chose
to have text in an idea underlined as this is used to denote that the idea has a hyperlink
attached to it.

Format Group
The Format group options let you change the text for an idea note.

The Bullet button will add or remove bullet points to the text in the idea notes.
Use Decrease Indent and Increase Indent to change the indentation of the text
in an idea note.
Use Left Align, Centre and Right Align to alter the text alignment of your
idea notes.

Note: the Format group is only displayed when focus is in the Notes For pane.

Idea Group
The Idea group will be displayed as either Current Idea or Default Idea. The Current Idea
group is displayed when one or more ideas have been selected in the idea map.

Changed made using the Current Idea group effect only the currently selected
idea/ideas.
When no ideas are currently selected on the idea map, the Default Idea group is
displayed.

Changes made using the Default Idea group effect all subsequently created ideas on this
idea map.

Ideas can have one of four different styles:
•
•
•
•

None: no colour choices
Solid: one colour choice
Gradient: two colour choices
Centre Gradient: two colour choices

Depending on the chosen Style, there will be a choice of up to 2 different colours.

Ideas can be represented on the idea map by one of the predefined shapes. To
remove the shape from an idea select the red cross in the Shape drop down list. The
Idea will then be displayed as either text only or with text and an image.

Text displayed within an idea on the idea map can be positioned in one of 9
grid positions.

If the idea displays an image, you can also position it to one of the 9 grid
positions or you can fit or stretch the image to the shape.

Note: When only a link is selected on the idea map, the Idea group of the ribbon is not
displayed.

Adding sound to your Ideas
Sound can be added to your ideas using the sound options on the Current Idea group.

To record your own sound file for an idea, select the idea and click on the Record
button.
When you have finished recording your sound click on the Stop button. Notice that
when a sound has been associated with an Idea, the Idea is displayed with a red border
and red text.
Note: You will need a microphone attached to your computer to record your own sounds.
Another way to add sound to an Idea is to select a previously created audio file using
the Browse for Audio button. Navigate to the required wav file and click on the Open
button. ClaroIdeas will show that a sound file has been associated with the idea by
changing the border and text colour to red.
When an Idea which has sound is selected you can click on the Play button to hear
your recorded sound. During playback, the Play button will become a Pause button
allowing you to pause the audio at any time.
Note: You will need speakers or headphones attached to your computer to hear your
recorded sounds.
To remove a sound from an idea use the Delete Audio button. This works for audio
you have recorder yourself and for when you have selected a previously recorded sound
file.
Note: the Sound options are not available on the Default Idea group.

Whole Map Group
The Whole Map group options lets you make changes to the whole of your idea map.

You can add an image as the background or change the background colour. To remove
an image from the background, select the Clear menu item on the Image menu.

You can change the layout of your idea map to either Free form, Centred, Left
to Right, Top to Bottom, Bottom to Top and Right to Left, by using the Layout
dropdown selection. Once you have selected a layout option, ClaroIdeas will keep the
layout for any new ideas you add to the idea map unless you have chosen Free form.
Having selected a layout option you can also change the style of the links from one of
Straight, Curved or Step.
Choose the line width of the outline of the ideas and links using the "Line Width" section.
Choose from Light, Medium or Thick.

For all ideas on the idea map, you can turn on or off Emboss and Shadow using
the options on the Style drop down menu.
If you would like to have a grid displayed on the idea map background select the Grid
option on the Style drop down menu. The grid can be useful when arranging you ideas
on the idea map e.g. to help you to line up your ideas with each other.
Note: If you print your idea map the grid will not be printed.

Hyperlinks Group
You can link your ideas to Websites, to another idea map you have created or to any
other document which could be an image, a Word document or PowerPoint presentation
etc.

Adding and removing hyperlinks
Select the idea you want to add the hyperlink to and select which type of link you want
to add from the dropdown selections.
To add a hyperlink to either a Map or to another type of document, select the Browse
option in the drop down list and use the Open window to locate the required file. Click
the Open button to attach the hyperlink.

To add a Web hyperlink, select the Browse button to open your Internet browser.
Navigate to the required web page in the usual way and then copy the contents of the
browser's address bar into the clipboard. Close your Internet browser window and paste
the contents of the clipboard into the Web link field in the Hyperlinks group.
When an idea has a hyperlink attached to it, the idea is displayed with the idea text
underlined. To see what is hyperlinked to an idea, select the idea using your mouse and
look at the Hyperlinks group.

Opening a hyperlink
To open a hyperlinked document or web page, right click the idea with your mouse.

The pop-up menu will have options to display the linked map, Web page or document.
Note: You can add up to three hyperlinks to each idea, but only one of each type. I.e.
one Web link, one Map link and one Document link.

Link Group
Change the appearance of links on the idea map using the options on the Link group.

When one or more link is currently selected on the idea map, changes made using the
Links tools bar will affect only the selected link or links.
If no links are currently selected then any changes you make using the Link group will
affect all subsequently created links.

The link style can be set to one of Straight, Wavy or Step.

Arrows can be placed at the end of links or, for some styles, in the middle
of links.

Where an arrow is displayed on a link, the colour of the arrow can also be
set.
Set the link style, colour and arrow types using the dropdown list options.

Idea Map Views Group
Use the Idea Map Views group to select how to view the map.

Select "Map View" to view the idea map and select "Outline View" to see a list view of
the idea map.
These buttons are also replicated in the bottom right corner of the window next to the
zoom functions.

Map View

Outline View

Show/Hide Group
Use the Show/Hide group to select what is shown in the left and right panels.
Alternatively, click on the X button in the top right of each pane to hide them.

Outline Overview
Checking this option shows the idea map outline overview in the left hand panel.

Folder View
Checking this option shows the folder view in the left hand panel. Select images and
other idea maps from this folder view.

Autocreate
Checking this option shows the Autocreate box in the right hand panel.

Idea Notes
Checking this option shows the idea notes in the right hand panel.

Context Help
Checking this option shows the context help information in the right hand panel.

Map Overview
Checking this option shows the map overview in the right hand panel.

Zoom Group
Use the Zoom group to view the map at different zoom levels.

Zoom
This button will open a Zoom window allowing you to customise the zoom level of the
map.

100%
This button will set the zoom level to 100%

One Page
This button will set the zoom level so that the whole map fits in the available map area.

Page Width
This button will set the zoom level so that the width of the map fits in the available map
area.

Page Height
This button will set the zoom level so that the height of the map fits in the available map
area.

Quick Access Toolbar

The quick access toolbar can be used to allow easy access to frequently used features of
ClaroIdeas.

When ClaroIdeas is first installed, the following standard buttons are available on the
Quick Access Toolbar:
•

New: start a new idea map

•

Open: open an existing idea map

•

Save: save the current idea map

•

Print: print the current idea map

•

Undo: undo the last action

•

Redo: redo the last action

Adding and removing buttons
You can display other buttons on the Quick Access Toolbar. To add a button, right click
the desired button on the ribbon and select the menu item Add to Quick Access
Toolbar.
To remove a button from the Quick Access Toolbar use the Customise Quick Access
Toolbar menu which can be found at the right side of the Quick Access Toolbar.

Moving the Quick Access Toolbar
The Quick Access Toolbar can be displayed either above or below the main ClaroIdeas
group. To change where the Quick Access Toolbar is displayed, use the Show Below
the Ribbon menu item in the Customise Quick Access Toolbar menu.

Building Idea Maps
New idea maps start with a single main idea. You build the idea map by adding new
ideas to it.
Your ideas can then be further enhanced by adding images, notes, audio and hyperlinks.

Ideas
Adding ideas
One way of adding new ideas to your idea map is to use the Autocreate feature. This is
probably the simplest way of quickly adding several ideas to your idea map. (See Ribbon
- Autocreate Group)
Another way to add ideas is to click on the idea to which you would like your new idea
linked and then drag your mouse to an empty area of the idea map. When you release
your mouse a new idea will be added along with a link to the source idea. The new idea
will have the same properties as the idea which was the source of the link, but
remember you will have to set the text of the new idea.

Note: You when adding ideas by clicking and dragging in this way, you must release the
mouse in an empty space. If you release the mouse over an existing idea a link will be
created between the two ideas.
You can also add new ideas to your idea map by clicking and dragging within the
workspace. As you drag your mouse you will see the size of the new idea. When it is the
correct size, release your mouse.
Note: Ideas added the last way will not be linked to anything, so you will need to create
the link(s) yourself.

Moving, resizing and rotating ideas
When an idea is selected in the idea map, several hot-spots are displayed in and around
the idea. You can use these hot-spots to create new ideas, move, resize and rotate the
idea.

When you move your mouse over the hotspot in the centre of the idea it changes to a
Hand mouse pointer. Clicking and dragging to an empty space in the map creates a new
idea. Click and dragging to an existing idea links the two ideas.

When you move your mouse pointer over the idea it changes to a Move mouse
pointer which usually has four arrow heads. Clicking and dragging your mouse when this
mouse pointer is displayed allows you to move the idea to a new position on the idea
map.
Note: If you move an idea which has other ideas linked from it, they will also be moved
so that they maintain the same relative position.

When your mouse pointer moves over one of the hot-spots around the
edge of the idea it changes to a Resize mouse pointer which usually has two arrow
heads. Clicking and dragging your mouse now will allow you to resize your idea.
There is an additional hot-spot positioned above the idea which is circular rather than
square. You can click and drag on this hot-spot to rotate your idea around its centre
point.

Selecting ideas
When you click your mouse on an idea it is selected. Sometimes you may want to select
more than one idea at a time.
You can use the right mouse button to click and drag a box around several ideas. All of
the ideas which are contained within the box when you release the right mouse button
will be selected.
You can also select more than one idea by holding down the Ctrl key while you click on
several ideas. Each idea you click on will be selected. If you select an idea by mistake,
simply click it again to un-select it. Remember to hold down the Ctrl key until you have
finished selecting all of the ideas you wish to select.

Reordering ideas
To reorder ideas, select a layout option from the Layout section of the Whole Map group
in the ribbon except Free form or Centred. Now:
1. Click on an idea that you want to reorder
2. Drag it to where it should sit (this place must be under the same parent idea as
the idea you are moving)
3. Let go of the mouse button and the ideas will be reordered

Deleting ideas
To delete the selected idea(s) either press the Delete key or right click on an idea and
select Delete Idea.

Idea Images
On the left side of the screen you will see the Folder View. ClaroIdeas has many images
for you to use in your idea maps and you can also use your own images.
Note: If you cannot see the Folder View, check "Folder View" is checked in the View tab
at the top and/or click on the arrow on the right-hand side of the ClaroIdeas window.
(See Customising the ClaroIdeas Window)
If you click on the Folder View button a dropdown list will appear with a
number of different folders to choose from.
To chose one of your own pictures to use in your idea map, click on the
Browse button. You can now navigate to the correct folder on your computer and click

the OK button. A list of the pictures in the selected folder will be displayed in the folder
view.
You can add an image to an existing idea by dragging and dropping the image over the
existing idea. The image will be added to the background of the idea.
Use the Image button on the Current Idea group to adjust the position of the image
within the idea. (See Ribbon - Current Idea Group)
You can also add an image to your map by dragging and dropping from the folder view
to an empty space on your idea map. This will create a new idea on the idea map, but
note that this idea will not be linked to any of the existing ideas. You will need to create
a link to or from this idea manually.
To remove the picture from an idea, select the shape and then right click on it. Choose
the menu item Remove picture.

Idea Text
To add text to an idea you can select the idea and either press Enter, F2, double click or
right click and select Edit text and an editing text box will appear. To add line breaks
press Shift and Enter. To stop editing press Enter or click away from the idea.
You can use the Align Text button on the Current Idea group to set the position of the
text within the idea.
Use the Font group options to change the style and size of the text. (See Ribbon - Font
Group)

Idea Links
Links between your ideas can be added or removed as necessary.
To create a new link, simply click your mouse on the idea where you want the link to
start, drag your mouse to the idea where you want your link to end and then release the
mouse button.
To remove a link, first select it using your mouse, then either press the Delete key or
use the Delete button on the Clipboard group.
The display properties of links can be changed using the options in the Links group. (See
Ribbon - Links Group)

Idea Notes
It can be useful to add notes to your ideas. This allows you to include extra details for
your ideas without having those details displayed on your idea map.
To the right of the main idea map workspace is a pane where you can enter notes for
your ideas. As you select ideas on the idea map, the title of the Idea Notes pane changes
to reflect the current idea.

You can simply click into this pane and type additional notes associated with the idea.
Text in the Idea Notes pane can be formatted using the Font and the Format groups.
(See Ribbon - Font Group and Ribbon - Format Group)
You can cycle through all the idea notes using the previous and next arrows next
to the Idea Notes title.
Note: If you cannot see the Idea Notes pane, ensure the "Idea Notes" check box is
checked in the View tab of the ribbon (See Show/Hide Group) and/or click on the arrow
on the left-hand side of the ClaroIdeas window. (See Customising the ClaroIdeas
Window)

Showing and Hiding Ideas
At times, you may wish to only display certain ideas on your idea map. To allow this
ClaroIdeas displays a Hide/Show symbol next to each idea.
Click on the Hide button to hide all ideas which have links starting at this idea.
Click on the Show button to display previously hidden ideas which have links starting
at this idea.

Enhance your Ideas
Add hyperlinks to web pages, other idea maps or any other document using the
Hyperlinks group. (See Ribbon - Hyperlinks Group)
Add audio to your ideas using the Current Idea group. (See Ribbon - Current Idea
Group)

File Menu

From the file menu you can create new idea maps; open existing idea maps; save
your idea maps; export your idea maps to use in other applications; and print them.

Create a new idea map

To create a new idea map, use the New option on the file menu.

A new idea map will be displayed with your main idea.

Open an existing idea map
When you first open the File menu, ClaroIdeas displays a list of the idea maps you have
most recently opened.

If you cannot see the idea map you want in the Recent Maps List, use the Open option.

Save your idea map
You should always save your work regularly. To save your current idea map use the
Save menu item on the File menu.

You can create a new copy of your idea map, or change its name by using the Save As
menu item on the File menu. After selecting this option you will be given the option to
chose a new name and location for your idea map. When you are ready click on the
Save button.

Import from other applications
It is possible to import ClaroCapture projects into ClaroIdeas using the Import feature.

Click on the ClaroCapture menu item and select a ClaroCapture project file (.ccp).
ClaroIdeas will now create an idea map from the project file.

Export to another application
At some stage, you may wish to utilise your idea map by working with it in a different
application. You can export your idea maps into Microsoft Word and Microsoft
PowerPoint, or you can convert your idea map into either a PDF (Portable Document
Format) file or a PNG (Portable Network Graphics) file.

Click on either Word or PowerPoint on the Export To menu and ClaroIdeas will open
the relevant application and create a new document. The new document will contain all
of the ideas from your idea map.
If you chose to export to a PDF file or a PNG file, ClaroIdeas will first prompt you to
select a file name and location for your chosen file. When you have done this and clicked
the Save button, the file will be created.

Printing idea maps
To print your idea map select the Print menu item on the File menu. You will be given
the option to select your printer, the number of copies your require and other options
before printing.

Print Preview

Before you print your idea map you may prefer to check how it will look on paper. You
can use the Print Preview menu item on the File menu to do this.

The Print Preview window has its own toolbar which you can use to change the way your
idea map will be printed.

Use the Print button to print your idea map on your default printer or use the
drop-down list of printers to chose an alternative printer.

Use the drop-down list on the Zoom button to change how large your idea map is
displayed in the Print Preview window. This does not change how large the idea map will
be printed. For that, use the Resize button.

You can quickly change how many pages are displayed in the
Print Preview window by clicking on one of One Page, Two Pages, Three Pages, Four
Pages or Six Pages.

When a idea map spans multiple pages you can move between
the pages using the First Page, Previous Page, Next Page and Last Page buttons.
The number in the centre of these buttons displays the page number of the currently
displayed page.

To change how large the idea map will be printed you can use the Resize
button. The options are:

•
•
•
•
•
•

Fit To Page: resizes your idea map so that if fits onto a single printed page.
Original Scale: sets your idea map to be the size you created it.
Double Scale: increases the scale to double that which is currently set in the
Print Preview window.
Half Scale: decreases the scale to half that which is currently set in the Print
Preview window.
Increase Scale: increases the scale from how it is currently set in the Print
Preview window.
Decrease Scale: decreases the scale from how it is currently set in the Print
Preview window.

You can use the Double Scale, Half Scale, Increase Scale and Decrease Scale menu
items repeatedly to fine tune the size that your idea map will print.

The Landscape/Portrait button switches between these two printing modes.

Viewing your idea map
There are a number of ways to view your idea maps, you can:
•
•
•

Zoom in
Look at the map overview
Customise the view

Zoom
You can zoom in and out of your map using the options at the bottom right of the
screen.

The One Page button will resize the idea map to fill the current size of the window.
The Page Width button will resize the idea map to fit the width of the map into the
map window.
The Page Height button will resize the idea map to fit the height of the map into the
map window.
For manual adjustments you can use the slider bar to change the magnification level to
the required setting between 10% (smallest) and 400% (largest). A small line on the
slider bar shows the position of 100%.

Idea Map Overview
As you add to your idea map it will probably become quite large and will not fit into the
workspace of ClaroIdeas. There is a preview pane at the bottom right-hand side of the
ClaroIdeas window which allows you to easily navigate your idea map. If you cannot see
the overview pane, ensure "Map Overview" is checked in the View tab in the ribbon.

The whole of your idea map is always visible in the preview pane, and the highlighted
section shows the part of the idea map which is currently visible in the workspace.
You click on this preview pane to navigate around your idea map, or you can use the
scroll bars provided along the bottom and right-hand edges of the workspace.

Customising the ClaroIdeas window
The different sections of the ClaroIdeas can be hidden or resized depending on the task
you are performing. This can help when you are building your idea map as it increases
the amount of workspace available to view your idea map.
You can hide or show the ribbon by selecting the menu item Minimise the Ribbon on
the Quick Access Toolbar menu. (See Quick Access Toolbar)

You can hide or show the left panel by clicking on the arrow located on the left edge
of the ClaroIdeas window. (See Idea Images)

You can hide or show the right-hand section which displays autocreate, help, notes
and viewing options by clicking on the arrow located on the right hand edge of the
ClaroIdeas window. This section can also be resized by dragging the vertical dividing line
with your mouse. (See Idea Notes)
These different windows can be hidden or shown using the Show/Hide group in the View
tab of the ribbon.

Keyboard Shortcuts
Function

Shortcut

New

Ctrl + N

Open

Ctrl + O

Save

Ctrl + S

Save As

Ctrl + Shift + S

Undo

Ctrl + Z

Redo

Ctrl + Y

Autocreate

Ctrl + Shift + A

Bold

Ctrl + B

Italics

Ctrl + I

Delete item

Del

Edit idea text

Select idea + F2

Select all ideas

Ctrl + A

Show Ribbon shortcuts

Alt

Focus on Outline Overview

Ctrl + F2

Focus on Folder View

Ctrl + F3

Focus on Autocreate

Ctrl + F4

Focus on Idea Notes

Ctrl + F5

Focus on Context Help

Ctrl + F6

Contact Us

We would like to thank you for using ClaroIdeas.
You can see more Claro Software products at www.clarosoftware.com

If you have any queries, please visit our help pages at help.clarodownloads.com or
contact us at support@clarosoftware.com
We value your feedback.
Claro Software Ltd
Tel: +44 (0)1772 977 888
US Toll Free: 1-866-800-5151
www.clarosoftware.com

